Home English Alliance News & Diplomacy

Support-reward glitches??

Anyone else experience this.  The last few upgrades have caused some issues.  I opened a ticket Sept. 24th.  No reply as of yet.  Happening again this event.  I was not on the for over 32 hrs, logged on and saw that our alliance rewards for sami were never sent to main.  I had no losses, so could not have lost troops to starvation.  So again I am out over 500 troops plus tool rewards.  This is getting absurd.  Why should players make the effort to work so hard getting rewards for alliance, and yet they don't get delivered to main of players that were not on when they were won.  I verified with our members, the rewards pop up on screen if you are on.  In the past if you were not on and logged in you would see the rewards tab to claim them, but I understood they were automatically delivered when alliance won them.  So a MOD. needs to look into this, I have screen shots, but no one to send them to since support not answering! 
WizardDD @ US1

Comments

  • Lezley (GB1)Lezley (GB1) GB1 Posts: 2,694
    Getting my troops delivered when I'm offline. Used to be a week offline to not get them.
    Knowing trees, I understand the meaning of patience.
    Knowing grass, I can appreciate persistence.
  • Thank you Lez.  Still would be good of Customer service if they would reply, ticket open since Sept. 24th. Dissatisfied with always having to wait, or get no reply at all.  Outrageous actually.     I'm sure I was not offline a week. :wink:
    WizardDD @ US1
  •  >:)  >:):|:|:#
  • Why am I not surprised to get the standard text book answer/reply from GG after waiting over 30 days.  Did they think I would forget what happened.!!
     This is what I was told

     "In order to be able to get the alliance rewards you would need to be active during the event and to also partake in the event as well. Logging on just for a few hours during the event one day will not get you any of the rewards.

    Sorry for the delay in getting back to you and I hope this solves your issue."

    So why after logging in after being offline since last night did i just receive all the alliance rewards won to date, 100 sami troops, several hundred tools and 150 flags. Hmmm. yet I sent no attacks to sami yet!  BS reply again.!





    WizardDD @ US1
  • Because people would complain when they don't get the rewards already handed out when they finally attack their first sami.  They don't have a way to retroactively give rewards, but they can tell who didn't participate and not hand out awards that are meant for top 20, etc. at the end.
    Master Chaz @ GG 1
  • Because people would complain when they don't get the rewards already handed out when they finally attack their first sami.  They don't have a way to retroactively give rewards, but they can tell who didn't participate and not hand out awards that are meant for top 20, etc. at the end.
    That's not the issue, player awards are different, yes, I get more rewards if I attack, since it is given for ranking!  

    Game always gave the alliance rewards even if you were not on, otherwise how did I accumulate thousands of sami tools, FL tools, etc.   If they changed it within the last few upgrades, ok, tell us.  But why did I get the rewards yesterday when I first logged on after being offline, I did not send ANY attack yet!

     SO THIS STATEMENT IS UNTRUE!

    "In order to be able to get the alliance rewards you would need to be active during the event and to also partake in the event as well. Logging on just for a few hours during the event one day will not get you any of the rewards. "

    WizardDD @ US1
  • Many rewards diff events not being given out they've shorted me close to 20 pcs of relic equipment in Berrimond last Outer Realms nobody got relic building tokens. And spent 3 weeks and 500k resourses to research wood storage build item only to have it not activate. Sent in ticket no record of it being received.

  • At least you guys can send a ticket to support. I have not been able to pick a subject under issue. The drop-down arrow won't work and hasn't worked in months. I double clicked the arrow triple click the arrow and nothing. I go to support here and the drop-down arrow to change the server from Arabic to us 1 and still the arrow doesn't let me pick anything.

Sign In to comment.