Home English (UK) Technical Assistance

We need new Moderators!

ModeratorWe are always on the lookout for talented people to join the team. That means you! If you think you could help us organise and inform the community while entertaining everyone then apply. We need people to help out on the forum, behind the scenes with announcements, on Discord and on our other Social Media channels.

If this is something you think might be of interest to you, HERE

Technical Issues 17/6



  • jamman (US1)jamman (US1) US1 Posts: 106
    I've have never seen such a ridiculous game
    where literally EVERYTHING goes wrong

    That is SOOOO not true.

    1 - The popup ads are displaying flawlessly (and constantly)


    2 - the Buy RUBIEs offers are working too


    3 - Chat entries show up (at least half the time) ... and only 4 or 5 minutes after you actually type them

    I think a more reasonable estimate would be something like 99.99% of what the PLAYERS need/want in order to play the game is messed up, or not working.

    But hey! You can't always get what you want, right?  o:)

    jamman @ usa 1
  • Roptaman (NL1)Roptaman (NL1) NL1 Posts: 12
    GGE=Good Gigantic Error
  • andybash (GB1)andybash (GB1) GB1 Posts: 16
    its a joke no compo they blame weather next
  • @Temprance So that's 2x $50 booster down the drain, what will be provided to make up for this ?
  • Thanks Jamman
  • Sorth121 (US1)Sorth121 (US1) US1 Posts: 215
    @Temprance So that's 2x $50 booster down the drain, what will be provided to make up for this ?
    A nice 100 1% beri booster tools of course. 
    MUFU Member

  • I finished 6 of the daily tasks this morning and none of them even got credit for being done.
     Not even the daily log in...every update is yet another *snafu*.
    Its annoying af to have these daily problems. 

    Queen NunYa @ usa 1
  • urgh down again hey this aint funny
    has anyone else had the problem of   quests showing 0  daily tasks not budging and  spy  camp showing all rewards being done but nothing changes in accoun t inventary
  • flug (NL1)flug (NL1) NL1 Posts: 1,484
    Temprance said:
    To start, flash player has been removed cleanly and version 29 has been successfully installed with no update check with verification that the update service does not exist so no auto updating.  Just in case, I have checked and rechecked and my computer is still running flash player 29.  So that's out of the way.

    Since downgrading to flash player 29, the game has been working fine with good responses.  This morning the game is lagging in a new way.  The best way to explain is that if I click on something like hiring a new attack unit in beri, if I move away from the window before it shows up, I get an error like this can't be done because the unit is unavailable in that castle.  It take something between 10 seconds and 30 seconds for the game to respond where I can move on.

    The game is unplayable at this point as each click has to be followed by up to half a minute of wait.  The only thing I can do at this point is to make sure nothing starves and probably sit on the screen on the side in case of attacks.
    Correct, the recent rise in lag is not related to Flash and a hotfix is being prepared to improve the game performance. 

    Please note, food will be frozen until 4:00pm CEST.

    first food is frozen till 7.00 now till 4?   how come?
    flug @ nl 1
  • pit bull (GB1)pit bull (GB1) GB1 Posts: 20
    still cant log on the uk server
  • Seems like pretty poor form to release an update at 16;20 on friday afternoon... knowing that you won't be here for 2 days to address any issues that may arise...

    This all started running really poorly right after that update...

    A thought for the future maybe...
  • hey so i not the only one addicted  and  cooling my heels  sigh
  • well lm not this kind of player who will say gge the best if  l see this many bug in game 
    l dont care  events ect ect 
    but when log in game  want to play and have fun with friends in game 
    but no way untill so much bug in game .
    time to  gge do something 

  • Nambala (AU1)Nambala (AU1) AU1 Posts: 172
    OxO (AU1) said:
    having the same problem and bought the 500% beri booster to finish the queens quest for galantry, not happy!
    You really are a twat, aren't you OxO.  I'm sure you'd find it just as hilarious if it happened to you. 
    Nambala @ au 1
  • going to watch a movie sigh  rather be playing but since they fiddling again hope something interesting appears
  • Domlin (US1)Domlin (US1) US1 Posts: 148

    After this can you work on reducing the CPU usage for this game? I mean, there is literally nothing happening. The game just sits there. My laptop battery cries when I start GGE.

    Domlin @ usa 1
  • Asscuter said:
    I tryed loggin in but id doesn't let me :( I tryed out going in another browser still the same!!
    Me 2
  • When will I can go online
  • we are up and running again and what is the first thing on the screen 5 more pop ups that's the way to go




    LV 70 @ en 1
  • Kiwikiler95 (AU1)Kiwikiler95 (AU1) AU1 Posts: 419

    put our server back down and fix it still the same shit im sick of having to use puffin

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file