We are once again looking for some awesome new moderators to help us out with keeping
the forum running and playing a crucial part in our Empire community! If
this is something you think might be of interest to you, HERE

Royal Event Broken again ?

UltraFlavoured (GB1)UltraFlavoured (GB1) Posts: 954GB1
edited 13.03.2018 in Technical Assistance


Royal Quest seems to want me to hit Camps. The Camps from Berimond Invasion not the current one thats playing.

EDIT :PLAYER CAMPS REGISTER. FUN TIMES


~Ultra
Disclaimer:
Everything I say is strictly personal opinion and not in relation to my alliance or affiliates.

Ultra - First and Last.
Back to Break Some Balls - You Miss Me ?
Poking the bear since 2013.
Post edited by UltraFlavoured (GB1) on

Comments

  • Yes same problem here..
    Horik @ USA
    [email protected] AUS

  • Goselotje (NL1)Goselotje (NL1) Posts: 290NL1
    edited 13.03.2018
    the camps you attack in Berimond also count for the Royal event.
    So I see no issue with the royal event

    Gossie @ spilgames int_1
    Finally back where I belong in Legion
  • UltraFlavoured (GB1)UltraFlavoured (GB1) Posts: 954GB1
    edited 13.03.2018
    Are we talking player camps?

    ~Ultra

    EDIT: Turns out when you click the Camp button takes you to green but if you hit player camps in beri it works.


    Disclaimer:
    Everything I say is strictly personal opinion and not in relation to my alliance or affiliates.

    Ultra - First and Last.
    Back to Break Some Balls - You Miss Me ?
    Poking the bear since 2013.
  • CBee (US1)CBee (US1) Posts: 210US1
    this is because berimond green was suppose to be running today,  but since the nomads busted we got green beri early.  so basically its a cluster snowball effect of GGE glitches and fixes.
    CBee @ usa1


  • yeah same problem gb1 server  .. GGE never get it right
Sign In to comment.