Home English (UK) General Discussion

Join the official Goodgame Discord today!

Are you looking for a community of like-minded gamers to discuss your favorite games with? Look no further than the GoodGame Empire Family Discord Server!

Our server is the perfect place to connect with other gamers from around the world. Whether you're looking to chat about strategy, share tips and tricks, or just make new friends, our community has got you covered.

And that's not all - as a member of our Discord server, you'll also have access to exclusive giveaways and other special events. It's the perfect way to stay up to date on all the latest news and updates from GoodGame Studios.

So what are you waiting for? Join the GoodGame Empire Family Discord Server today and start connecting with fellow warriors from all over the world. Just head to https://discord.gg/goodgamestudios to join the fun!

Temporary solution

Imperius (GB1)Imperius (GB1) GB1 Posts: 1,088
edited 11.02.2017 in General Discussion
Hi all,
As frustating as it is there's a workaround which is the Puffin Browser on the mobile here's a guide from @Breor (US1) that explains the steps.
Right now the Puffin browser works but Google Chrome, IE, Opera etc... aren't working right now could be a number of issues with adobe flash or could just be the servers overloaded if you need help with anything just message me,
Regards David
Imperius @EN1

Post edited by Imperius (GB1) on


  • Crusader (AU1)Crusader (AU1) AU1 Posts: 14
    was able to log on using puffin and message alliance. now even that is frozen on the oiling chain mail. Hopefully this is not the case for many others
  • berty23uk (GB1)berty23uk (GB1) GB1 Posts: 13
    iv been loading the game up.leaving it for 15-20 mins.then click 'back' arrow leaving the page(not closing it) then instantly 'foward'arrow.but u must leave it a good 20 mins loading up on the gge log in page.hope it works for u guys
  • still stuck on oiling the chain mail
  • not work
  • not working here as well
  • NelsonP (AU1)NelsonP (AU1) AU1 Posts: 8

    Has been affecting players from 10/02/17 in my alliance and now myself.

    Hope there is a decent gift compensation package from GGE as from other people comments, it appears to be happening on several different browsers.

    Barfer @ au 1
  • ffffffffffffffffff
  • i found uninstalling google  and reinstalling it worked, but do not transfer bookmarks or passwords, history make it clean install.
    RareBandit @ en 1
  • bazwana (AU1)bazwana (AU1) AU1 Posts: 5

    I've tried standing on my right leg and holding a wire coat hanger in my left hand - didn't work either! Come on GGE, please!!!!

  • Still not fixed , what a joke
    Fisful Of Steel @ au 1
  • Have been trying to log in for hours. Would be nice for GGS to at least give an estimate of when they can have this fixed....

    I like that boulder. That is a nice boulder.
  • come on GGE you are now a joke in the Gaming world, ether fix it or lose customers, remember we pay your wages by buying rubies, if this problem goes on for much longer you will lose players like me
  • Lord Swaz (AU1)Lord Swaz (AU1) AU1 Posts: 17
    Still had problems sun morning

    switching to firefox has helped 4 me and at least allowed me in

    Site keeps saying does not supply security information
  • never had a problem with it. best way to do is install the app. if gge still doesn't work, attempt clearing the cache and generally the problem be fixed. just saying, this is just something as a tip from gge, your using the app at your own risk so don't go spinning complaints at them.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file