Home English (UK) Technical Assistance

Join the official Goodgame Discord today!

Are you looking for a community of like-minded gamers to discuss your favorite games with? Look no further than the GoodGame Empire Family Discord Server!

Our server is the perfect place to connect with other gamers from around the world. Whether you're looking to chat about strategy, share tips and tricks, or just make new friends, our community has got you covered.

And that's not all - as a member of our Discord server, you'll also have access to exclusive giveaways and other special events. It's the perfect way to stay up to date on all the latest news and updates from GoodGame Studios.

So what are you waiting for? Join the GoodGame Empire Family Discord Server today and start connecting with fellow warriors from all over the world. Just head to https://discord.gg/goodgamestudios to join the fun!

I cant play Empire!

smithy92smithy92 Posts: 106
edited 24.12.2012 in Technical Assistance
So everytime i log in, it comes up with the notice board, close that and below it is what looks like a new Resource Village naming screen, except there is no writing, it wont let me type in the box or press ok... and of course as long as its on my screen i cant play the game.

ive cleared history, cache, even tried a whole different browser... still not working!

Help, please?
smithy92 @ en 1
Post edited by smithy92 on


  • hassaan786hassaan786 Posts: 6
    edited 24.12.2012
    the exact same thing happened to me its so annoying. Anyone know how to get rid of this?
    hassaan786 @ en 1

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file