Home English (UK) Technical Assistance

We need new Moderators!

ModeratorWe are always on the lookout for talented people to join the team. That means you! If you think you could help us organise and inform the community while entertaining everyone then apply. We need people to help out on the forum, behind the scenes with announcements, on Discord and on our other Social Media channels.

If this is something you think might be of interest to you, HERE

Technical Issues 17/6



  • Clexafan8 (US1)Clexafan8 (US1) US1 Posts: 16
    i tried all suggestions, but if you have a windows 10 computer you are not able to actually revert back versions of adobe as it isn't a compatible option. 

    the only thing that allows windows 10 users to continue with gge is to use the windows version of puffin browser.  it is slower and graphics suck but it still allows you to play.
    but seriously ggs people need to fix this situation otherwise you are going to loose many loyal longtime players. 
    FabulousLaura @ au 1
  • GGE are you people really that bad, in few private messages you said sorry on delay drag and log in problems we will not run all stuff together again. Yet you've just done it again i have a 3-5 second delay after my first attack and within 15-20 mints i have refresh window; then new login takes 2-3 minutes get back in. Another pm said you were going let us drop Gem again for free not seen that. And my last complaint is i  want money back into my account iv'e spent for Rubies as i have built fountain and you take away the pennies; so maybe a Lawyer be way go as should net big amount cash with a Mega Suite with all people in here that built fountains.
    danielq @ usa 1
  • nana9903 (US1)nana9903 (US1) US1 Posts: 8
    i usually hit at least 3-5 rbc in just the world map each day. usually a maxed one gives me about 30k coins. well tonight there were no coins at all.  happened earlier to an alliance member in outer worlds as well. what is up with the "not getting coins" anymore.  USA1 server, Foxfire Browser, also tried stand alone flash player, same problem. I hit total of 18 towers for coins today and got everything but coins.
  • george59 (GB1)george59 (GB1) GB1 Posts: 6
    i cannot log in it goes straight to new build as if i was a new player & it freezes so i can't log it out or do anything.i have reported it fat chance of it getting sorted
    george59 @ en 1
  • age53 (AU1)age53 (AU1) AU1 Posts: 2
    Hi, I can't login in to Goodgame Empire game.  It was ok until about 4 days ago. Need help, thank you.
  • I have tried every combination of browser (Chrome, Firefox, Edge, Opera) and old (V26) and latest flash player and nothing works. Stuck with Puffin on Windows 10. Slow, graphics suck, can't use mouse scroll.
    GGE - You gotta fix this because I am ready to walk away.
  • Hi nana9903.

    I noticed the same thing. Then my allies pointed out to me that if you check the armies coming back - they are carrying the gold coins. 
    So you are still getting the gold.. it's just a display bug on the battle reports.

    Cheers Friend.

  • Hi all,

    when I tried to open the game, (which was working a few minutes ago) it just froze on the loading screen.... the usual animations weren't moving, but the loading bar was working. However, after a while, the loading bar would just disappear leaving me with a frozen screen. Help??

  • i am lvl 43 and should have many missions but my mission book is not opening and showing 0 on it i reloded the game but nothing happend pls help



    We are having a new start.A normal player can not join us.We only accept hunters.Now what is a hunter?Please read throughly.

    If any person wants to take revenge but he can not    No problem!
    We will.(only in international 1)

    How does it work?
    Attack:We only attack players from level 10 to 50
    1 Tell us the name by sending a private message in game
    2 Disscuss what you can give us(Food,Wood,Stone,RV,OP,Lab,Monument)
    3 Half ammount before attack/sabotage
    4 Half ammount after we send you a screenshot of mission
    Sabotage:We sabotage everyone(level 10 to level70)
    Why you should choose us:
    1 Reasonable price
    2 We dont leak info. like your name
    3 Special discount to our regular customers

    Prices will be disscussed in messages

    For a contract please contact:Abdullah2006,AbdulRehman2004,Ahmed2009
  • jim smith (US1)jim smith (US1) US1 Posts: 28
    Did a bunch of my daily tasks today, they don't reflect that they were done in the game. Refreshed several times, still not showing up.
    12345 54321
  • Goselotje (NL1)Goselotje (NL1) NL1 Posts: 295
    When we attack foreign castles the glory is no longer added in the rankings.
    Also the points in the long term event are nor counted.

    It is weekend, so it will not be solved before the end of the event.
    I was close at the the 7,5 million glory and it seems that because of this bug it will be not possible to make the glory for the hero.
    All 1,1 million glory I made is not added. Still standing on 6.091.013 glory for an hour

    Gossie @ spilgames int_1
    Finally back where I belong in Legion
  • JGJ (GB1)JGJ (GB1) GB1 Posts: 6
    There are no Quests showing and Beri  Galantry points are not being added on
  • On a 500% booster, but the gallantry points stopped adding for the last 3-4 hits .. anyone else having this issue ?
  • chalk (GB1)chalk (GB1) GB1 Posts: 11
    having the same problem and bought the 500% beri booster to finish the queens quest for galantry, not happy!
    chalk @ en1
  • flusha (US1)flusha (US1) Posts: 29
    edited 17.06.2018

    Yes, I have no booster on but gallantry still does not appear to register.

    EDIT: false alarm, it was just terrible lag

  • game is a bit broken right now, me as well everyhting is glitching I have 0 quests 
    glory from attacking FL not getting counted...
    Proud member of:   -musketeers- 
    was a member of
     Grumps SK, the brave BH, Victorious.
  • OxO (AU1)OxO (AU1) AU1 Posts: 962
    having the same problem and bought the 500% beri booster to finish the queens quest for galantry, not happy!

  • neuterable (US1)neuterable (US1) US1 Posts: 757
    System States seem to be lagging all over the place, to the point of being unresponsive. Stuff doesn't heal in the hospital, Tasks don't register, this is pretty bad.
    neuterable, shameless slaughterer of peasants, collector of princesses and fan of homestuck

    α ЯTFM ¿¿¿Want Free $tuff??? Then Go Write Santa a Letter ЯTFM Ω
  • OxO (AU1)OxO (AU1) AU1 Posts: 962
    Welcome to half of Aus1's pain

  • gopher42 (US1)gopher42 (US1) US1 Posts: 35
    same here.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file