Home English (UK) Technical Assistance

We need new Moderators!

ModeratorWe are always on the lookout for talented people to join the team. That means you! If you think you could help us organise and inform the community while entertaining everyone then apply. We need people to help out on the forum, behind the scenes with announcements, on Discord and on our other Social Media channels.

If this is something you think might be of interest to you, HERE

Bugwatch 27/09/2017 update - Old



  • how about actually paying off the free gift that came with the new update. As soon as I clicked the button to collect, it popped some error and then said 'gift already collected' We had several people in our alliance claiming the same problem.

    I know 12 yr olds that can write code better... and it will actually work!!

  • Bill C. (US1)Bill C. (US1) US1 Posts: 19
    I have not been able to remove weapons from any of my commanders started today
    Bill C. @ usa 1
  • Galiaus (US1)Galiaus (US1) US1 Posts: 120
    edited 29.08.2019
    (Removed, wrong thread. sorry about that.)

  • paintman (US1)paintman (US1) US1 Posts: 6
    On the castle overview/ resources overview the storage capacity went back to the default setting of 81,000. The amount that I can store doesn't seem to be affected, just the capacity amount shows the wrong amount from my upgrades, etc. Please correct, Thank you.

    paintman @ usa 1
  • farmer1 (NL1)farmer1 (NL1) NL1 Posts: 5
    honour ranking reward if i want to collect it says come again in 7 days . it still stays empty

  • mubeen1413 (INT3)mubeen1413 (INT3) INT3 Posts: 13
    After the new Halloween update i can't seem to spy a target every time i try to spy a target a screen with cogs appear and it freezes needs to refresh the page. Another is that number of time skips we can buy from the silver shop has been increased, i had bought all time skips before the update now after update it shows that i can buy time skips but whenever i try to buy it shows an error that maximum number of purchase has been made already.
  • Sam0001 (AU1)Sam0001 (AU1) AU1 Posts: 3
    It's impossible to finish the nobility contest which is for spinning the wheel, when there hasn't been a wheel to spin for over 5 hours, with an hour to go

  • Hello lovely community type people!

    Another day, another update  B)

    If you reckon you've found yourself an issue please do post up some details in this thread and we'll be more than happy to investigate the matter for you and escalate it if needs be.

    Happy hunting!

    - Manta
    Hi Manta please assist me with an issue regarding the new wheel of unimaginable afflunce (50 000rubies for 1 ticket), it is stuck at my castle for the next few days , i recently got to level 70 legendary 1 , since then i havent seen the original wheel of affluence(fortune) i have tickets accumalating and wish to use them ... is this a glitch or error or will the previous wheel of fortune return (900rubies for 50 tickets) ??? 


  • Thanks for your feedback @ikke261068 (NL1)

    This thread is for identifying and hopefully getting bugs resolved. If you would like to discuss the content of the new update we have a section for this here: https://community.goodgamestudios.com/empire/en/discussion/341026/discussion-thread-october-2017-update

    Thanks for your understanding on this! :)

    - Manta
    The game keeps showing me a speacial offer, if i buy 2500 rubies they would give me many rewards like decorative items, troops, extra rubies... ect. I tried it first and they gave me the special offer, there's another two offers where i should buy 9000 rubies and one where i should buy 15000 rubies and of course i would receive even more rewards with extra rubies BUT I RECEIVED NOTHING. I literally brought the rubies only for the special offer but i received nothing. I already contacted the support and told them about the 9000rubies offer and they didnt answer, and now i told myself that it should be okay and i would receive the items because it's impossible to happen a second time BUT I STILL GOT NOTHING.

  • MTNS_TOB (INT3)MTNS_TOB (INT3) INT3 Posts: 1
    tried to claim kingdom's league rewards, only to have it say everything is claimed when i am missing about half of the listed  regular (not ones i needed the pass for) rewards. looking in to it, I found that I only ever obtained 2 pieces of relic equipment from the KL promotion rewards, when I should have 4 (being at hunter level). despite this, the game says I have claimed all these rewards.
  • MartenE3 (NL1)MartenE3 (NL1) NL1 Posts: 135
    edited 28.01.2020
    I always wonder how on earth people manage to land questions on threads like these -you must've scrolled down sooo far to put the question here.
    Anyways, after I looked into it it seems to me that you are supposed to only earn 2 relic equipment pieces after promotion? So you actually didn't get anything wrong, however, if I am wrong (please double check) correct me.
  • Random castles that aren't in alliances, when you hover under their castle name it says they're a member or a general etc.
  • Since today's update it is impossible to send support to an alliance member as the support pop up does not appear after clicking the support button.
  • BoBski (GR1)BoBski (GR1) GR1 Posts: 120
    After today's update while the food production shows the same as before, I am -5000 extra per hour throughout the great empire. It's outrageous. In the main castle, in order not to be negative in food production, I can keep a number of defenders as 5 years ago ...
    BoBski @ GR 1
  • eL Dragon (ASIA1)eL Dragon (ASIA1) ASIA1 Posts: 2
    Buongiorno cari Moderatori , abbiamo un problema con il Khan . C'è bug nel attacco . non funziona ne il saltatempo e non si può attaccare . Chiediamo gentimente di risolvere. Grazie
    adry @ WWW 1
  • Roptaman (NL1)Roptaman (NL1) NL1 Posts: 13
    Why is it not possible anymore to time skip the Khan Tower ? Only 1 attack and then waiting the time?
  • today the king ludwig quest is to spin the wheel of fortune and get a prize and ive spun the wheel many times and havent received anything !!
  • Wasso (INT3)Wasso (INT3) INT3 Posts: 3,332
    today the king ludwig quest is to spin the wheel of fortune and get a prize and ive spun the wheel many times and havent received anything !!
    How many times have you spun it?  I do not know if it is different at level 49, but my quest requires 15 spins to get some fast feathers and then 80 spins to get some farm tools and fleet shields.  NOT worth it, IMO.

    If you haven't done that many AND think it is worth it, then just keep spinning...….
    Good night.
    Sleep well.
    I'll most likely kill you in the morning.

  • HEWILSON (US1)HEWILSON (US1) US1 Posts: 15
    I can not access the SuperSale section to purchase affluence tickets. my section is blank.   I asked the members in my alliance they all can see the tickets. 
  • Malatar (US1)Malatar (US1) US1 Posts: 4
    Deco items (all) gone after last nights event ending. I'm especially concerned about the Fusion items I collected...this seems system-wide and across all servers...I would like them back....let me know what you plan to do about this one...
    Malatar @ usa 1

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file