Home Technical Assistance

We need new Moderators!


ModeratorWe are always on the lookout for talented people to join the team. That means you! If you think you could help us organise and inform the community while entertaining everyone then apply. We need people to help out on the forum, behind the scenes with announcements, on Discord and on our other Social Media channels.


If this is something you think might be of interest to you, HERE

cant login again...

i cant log into my account
its freezing on loading screen can someone please help me?

:) JRBRITTAINUSER @ usa 1

«1

Comments

  • Imperius (GB1)Imperius (GB1) GB1 Posts: 1,020
    Getting any error? 
  • :) JRBRITTAINUSER @ usa 1

  • someone please help ?

    :) JRBRITTAINUSER @ usa 1

  • does this happen on different browsers? computers? isps?
  • its not my computer its the game

    :) JRBRITTAINUSER @ usa 1

  • so then your answer is no, no, no?

    how come the game doesn't like you specifically and not me?
  • I still need help here, still not letting me log in, I got 2000 troops to feed

    :) JRBRITTAINUSER @ usa 1

  • my friend most of my alliance is haveing that problem  there is nothing that has been done they just set back laughing i guess
  • OxO (AU1)OxO (AU1) AU1 Posts: 962
    switch browsers, I find that chrome is the most compatible one to use for GGE



  • i used internet explorer, chrome, firefox and more

    did not work for me

    tried deleting browser data and reseting it

    did not work


    :) JRBRITTAINUSER @ usa 1

  • ok its my test server account, finally found a way to log in to US1 and INT1 servers

    :) JRBRITTAINUSER @ usa 1

  • ok its my test server account, finally found a way to log in to US1 and INT1 servers
    how??

  • changed a few settings and had to reset computer

    :) JRBRITTAINUSER @ usa 1

  • thanks that isn't very much help

  • Didee (US1)Didee (US1) US1 Posts: 21
    edited 20.04.2017
    Hi Mitchelle Lynne :) Just could not resist  joining the growing club!  I can log on from Mozilla Firefox but its like I am still far from playing as I cant even send food or visit my other castles.  Chrome which is my preferred browser is not cooperating.  My screen stays on Sharpening swords and if I do get some movement its because I get a message saying I am not connected and to try to reconnect... then page shows movement but wont go anywhere with  Kidnapping the princess. So either way it seems the game does not fully load. That about clearing cache does not work either.
    Didee @ usa 1
  • ok there is no customer support and I posted here two days ago. I can not get my login to finish loading. Have tried multiple browsers, computers. I get first two screens of load and it freezes on the big shield with nothing there after sharpening the swords.  I have cleared caches on browsers, Adobe flash player, and cleaned the computer. Then used friends desktop and laptop. Nothing works it is the same place on every computer. How do I get back into the account granny on the test server? It has been 8 days now the guys in my alliance tell me my account lights up green and as online when I try to login Please help me.
    gail y smith @ usa 1
  • Raggle Fock (US1)Raggle Fock (US1) Posts: 1,396
    edited 20.04.2017
    ok there is no customer support and I posted here two days ago. I can not get my login to finish loading. Have tried multiple browsers, computers. I get first two screens of load and it freezes on the big shield with nothing there after sharpening the swords.  I have cleared caches on browsers, Adobe flash player, and cleaned the computer. Then used friends desktop and laptop. Nothing works it is the same place on every computer. How do I get back into the account granny on the test server? It has been 8 days now the guys in my alliance tell me my account lights up green and as online when I try to login Please help me.
    unfortunately customer support can only be reached by emailing support. This forum are for general aid.

    https://community.goodgamestudios.com/empire/en/discussion/113891/how-do-i-contact-support#latest
  • Didee (US1)Didee (US1) US1 Posts: 21
    I contacted support and  what resulted is basically what is recommended here on forum. Clear cache , try different browser etc. and to get back to them if it does not work which I have done. Lost troops and cant stay on long enough on Mozilla Firefox to get anything done. Chrome which is my normally used browser is  not getting past the Sharpening swords. :(  
    Didee @ usa 1
  • so im not the only one thats had this happen 
    clear cache on chrome and click ctrl+r and it should pull up to where you can type in info
    that worked for me

    :) JRBRITTAINUSER @ usa 1

  • Didee (US1)Didee (US1) US1 Posts: 21
     Using JRBRTTAINUSERs advise ...It pulled up to where you can type for log in but it never opened up for me. the only thing I could hear was the music playing like when your in your castle. but never got into it. lol so why can I hear the music but cant enter my castle?  all this was after I cleared cache  if I try refreshing/reloading page it wont even get to the place where I can log in and I  cant hear anything .. And yes I am using Chrome
    Didee @ usa 1
Sign In to comment.