Home News from the world of Empire

We need new Moderators!


ModeratorWe are always on the lookout for talented people to join the team. That means you! If you think you could help us organise and inform the community while entertaining everyone then apply. We need people to help out on the forum, behind the scenes with announcements, on Discord and on our other Social Media channels.


If this is something you think might be of interest to you, HERE

Spring Event Schedule!

1235»

Comments

  • K1LLER (US1)K1LLER (US1) US1 Posts: 562
    I have encountered 3 issues in last 2 days:
    1) Day before Yesterday, I have bought an offer http://prntscr.com/ew9j36, and I have spent 10,000 Rupees on it, according to it i should get 7242 troops,however i got only rubies not troops.
    2)Yesterday my troops (4600 - 2300 ranged and 2300 Melle) suppose to return from my newly captured outpost(-MATADOR-) to my one of the outpost named OP2, But I am not able to find them now however their food consumption is still there. I have tried my level best to find it if i sent them to somewhere but nothing found in travel overview. I have deleted browser cache and re logged in, still the same situation. 
    3) Created tickets for both the issue and got same ticket number, :expressionless:  Ticket#201704141001  

    And the biggest issue with GGE is, they don't have man power and they take almost a month to reply on the tickets. 

    Question is if I am buying something to do something today, what the use to get it after a month.

    Also there is no compensation for the same from GGE.

    Ha ha ha:

    Found another bug when I was suppose to post this discussion:

    if you click on preview, below will be result:

    Damn, seems GGE testing team is damn lazy and they don;t know how to test the application.

    Regards,
    Ranjan Barua
    I have never had a problem with GGE support, although I am the 1% according the forum's complaining. It usually takes a little under a week to get everything through with GGE support.  
    My last time I had a prob I got an answer in 12 hours :P
Sign In to comment.