Home EN General Discussions & Questions

Join the official Goodgame Big Farm Discord today!Join our Big Farm Discord Server

Are you looking for a community of like-minded farmers to discuss your farming experience with? Look no further than the GoodGame Big Farm Discord Server!

Our server is the perfect place to connect with other farmers from around the world. Whether you're looking to chat about strategy, share tips and tricks, or just make new friends, our community has got you covered.

And that's not all - as a member of our Discord server, you'll also have access to exclusive giveaways and other special events. It's the perfect way to stay up to date on all the latest news and updates from GoodGame Studios.

So what are you waiting for? Join the GoodGame Big Farm Discord Server today and start connecting with fellow farmers from all over the world. Just click here to join the fun!


Dear MOD's and Fellow Farmers,

I don't know if any of you have experienced the error / or bug that I have been experiencing from yesterday evening. I had closed my laptop and I had to restart it when I opened it again and from that time on wards I have had this problem.

Normally when I click on the Big Farm Icon I have saved in Bookmarks, I was directly logged into my Big Farm account, this time I was directed to the Chinese Server Log In Page instead of to my account or to the International 1 Server page. I have been experiencing this from that time on wards and the only way that I can get to the International 1 Server Log In Pahich dge or directly to my account page is if I got to History of logged in web sites and click on the old log in to Big Farm prior to yesterday evening. This doe snot work all the time and I am having problems and would like some help in sorting this problem out.

Sometimes, what is also happening is that I get to the International 1 Server Log in page and when I enter my user name, it reflects as not known.

I am attaching two screen shots which depict this issue.

Please Help.




  • Uncle John (AU1)Uncle John (AU1) AU1 Posts: 10,720
    Why it is doing this to you I have no idea but
    at the top right of the screen where your first screenshot shows chinese characters (and your second shows "International"), you can always click the arrowhead and select INT1
    Both screen shots show "Log In" selected rather than "Register" which is correct (but easy to get wrong)
    With both those things right, as per your second screenshot, you should log on ok.

    I hope this helps (if only partially)

  • Jason33 (INT1)Jason33 (INT1) INT1 Posts: 63
    Hi Uncle John,

    Thanks for your input. Believe me when I say that I have tried almost everything, but its not happening as it should. In fact, when I have saved my log in details, user name and password in bookmarks, when I click on that bookmark I should be automatically directed to my account without being asked for user and password details. 

    I use Google Chrome to log in, I have tried logging in from other browsers like Opera and Mozilla Firefox but I get the same result. Chinese Server Log In Page.

    I also went to Region and Language in my Laptop to check whether my location had mistakenly changed to China.... :smile: But it hadn't...like this I am trying to rule out every possibility I can think of which could have caused this issue...but still drawing a blank....

    Take for instance...yesterday evening I was logged on under my user name and was enjoying playing the VF, today when I clicked on the Big Farm Icon in Bookmarks I got the Chinese Server log in page....a thought just struck me...could the Bookmark Icon have got corrupted...This is the thought I had...Like this I am one by one ruling out the things which may have contributed to this issue....

    Can someone Please Help!!

    Thanks You.

  • ijrosh (US1)ijrosh (US1) US1 Posts: 1,325
    i would clear all browser history along with cookies and some other saved data. so on chrome when you go to clear data hit the advanced button. then delete the bookmark you are trying to use. then go see if you can login then save that as a new book mark. sometimes the bookmarks or the links get messed up. especially if you mean the buttons when you first log on to chrome and not the actual book mark. but i have had book marks act up too. best way is just to delete them clear everything and re add them. if you have your log in info synced for all browsers. then using a different browser would not work cause it is using the same saved data. so try clearing and deleting the data. see if that helps.
    ijrosh @ us 1
  • Jason33 (INT1)Jason33 (INT1) INT1 Posts: 63
    Hi ijrosh,

    Thanks for your input.

    I deleted the Bookmark that I was using and logged into my account using a round about method and succeeded in getting to my account. YIPPEE!!

    Now I should see if I am able to connect through the new bookmark which I saved.

    I don't actually use any other browser than Google Chrome, but tried to log in via Opera and Mozilla Firefox browsers only to see if I could log in there. I used the URL on these browsers when I tried to log in, not via any bookmark.

    I am glad that I was able to log in and play the game today and hopefully will be able to as well tomorrow.

    Thanks Once Again!!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file